TLSv1.2 smjernice

  1. I. Rješavanje problema s kompatibilnošću
    1. 1. Ispitivanje kompatibilnosti preglednika za TLSv1.2
    2. 2. Ispitivanje verzije preglednika
    3. 3. Ispitivanje verzije operacijskog sustava
  2. II. Smjernice kompatibilnosti za TLSv1.2
    1. 1. Kompatibilnost operacijskog sustava
    2. 2. Kompatibilnost preglednika
  3. III. Nadogradnja u cilju kompatibilnosti
    1. 1. Koraci za omogućivanje protokola TLSv1.2 u pregledniku
    2. 2. Nadogradnja verzije preglednika
    3. 3. Nadogradnja verzije operacijskog sustava

I. Rješavanje problema s kompatibilnošću

1. Ispitivanje kompatibilnosti preglednika za TLSv1.2

Korisnik može testirati kompatibilnost svog preglednika za TLSv1.2, posjetom donjeg URL-a:
https://quickstream.westpac.com.au/quickportal/BrowserTlsVersionView

Preglednik je kompatibilan

Ako preglednik podržava TLSv1.2 korisnik će vidjeti sljedeće.

browser supports latest image version image needs to be placed

Preglednik nekompatibilan

Ako preglednik ne podržava TLSv1.2, korisnik će primiti sljedeću stranicu s onemogućenim TLS 1.0 i TLS 1.1.

browser needs to updated image version image needs to be placed

2. Ispitivanje verzije preglednika

Korisnik može ispitati verziju svog preglednika posjetom sljedećem URL-u:
https://www.whatismybrowser.com/

3. Ispitivanje verzije operacijskog sustava

Korisnik može ispitati verziju svog OS-a posjetom sljedećem URL-u:
http://whatsmyos.com/

II. Smjernice kompatibilnosti za TLSv1.2

1. Kompatibilnost operacijskog sustava

Operacijski sustav Verzija Smjernice za korisnika
Mac - Mac OS X 10.9 i raniji Vaš operacijski sustav ne podržava TLS 1.2 i potrebno ga je nadograditi na Mac OS X 10.10 ili noviji.
Ako nadogradnja operacijskog sustava nije moguća, uređaj treba promijeniti.
Windows - Windows 3.1
- Windows XP
- Windows 95
- Windows NT
- Windows Vista
Vaš operacijski sustav ne podržava TLS 1.2 i potrebna je nadogradnja na Windows 7 ili noviji.
Ako nadogradnja operacijskog sustava nije moguća, uređaj treba promijeniti.
iOS - raniji od iOS 7 Vaš operacijski sustav ne podržava TLS 1.2 i potrebno ga je nadograditi.
Ako nadogradnja operacijskog sustava nije moguća, uređaj treba promijeniti.
Android - Android 4.4 i raniji Vaš operacijski sustav ne podržava TLS 1.2 i potrebno ga je nadograditi na verziju 5 ili noviju.
Ako nadogradnja operacijskog sustava nije moguća, uređaj treba promijeniti.

2. Kompatibilnost preglednika

Google Chrome

Verzija preglednika Chrome Operacijski sustav Smjernice za korisnika
v1 do 29 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android
- iOS 9 i noviji
- Chrome OS
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v30 do 58 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android
- iOS 9 i noviji
- Chrome OS
Vaš web-preglednik je podržan.

Preglednik Google Android OS

Verzija Google Android OS Operacijski sustav Smjernice za korisnika
v1 do v4.0.4 Android Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v4.1 do v4.4.4 Android Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
v5 do v8 Android Vaš preglednik podržava TLS 1.2.

Mozilla Firefox

Verzija preglednika Mozilla Firefox Operacijski sustavi Smjernice za korisnika
v1 do v23 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android 4.0.3 i noviji
- iOS 9.0 i noviji
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v24 do v26 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android 4.0.3 i noviji
- iOS 9.0 i noviji
Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
v27 do v54 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android 4.0.3 i noviji
- iOS 9.0 i noviji
Vaš preglednik podržava TLS 1.2.

Mozilla Firefox ESR

Verzija preglednika Mozilla Firefox ESR Operacijski sustavi Smjernice za korisnika
v10 do v17.0.10 - Windows XP SP2 i noviji
- Mac OS X 10.9 i noviji
- Linux
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v24 do v24.1.1 - Windows XP SP2 i noviji
- Mac OS X 10.9 i noviji
- Linux
Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
v31 do v52.1 - Windows XP SP2 i noviji
- Mac OS X 10.9 i noviji
- Linux
Vaš preglednik podržava TLS 1.2.

Microsoft Internet Explorer

Verzija preglednika Internet Explorer Operacijski sustav Smjernice za korisnika
IE8 Windows XP Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
IE8 Windows Server 2003 Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
IE8 Windows Vista Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
IE8 Windows 7 Morate omogućiti podršku za TLS 1.2 u svom pregledniku
IE8 Windows Server 2008 Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
IE8 Windows Server 2008 R2 Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
IE8 Windows Server 2008 R2 Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
IE9 Windows Vista Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
IE9 Windows 7 Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
IE9 Windows Server 2008 Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
IE9 Windows Server 2008 R2 Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
IE10 Windows 7 Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
IE10 Windows 8 Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
IE10 Windows Server 2008 R2 Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
IE10 Windows Server 2012 Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
IE11 Windows 7 Vaš preglednik podržava TLS 1.2
IE11 Windows Server 2008 R2 Vaš preglednik podržava TLS 1.2.
IE11 Windows 8.1 Vaš preglednik podržava TLS 1.2.
IE11 Windows Server 2012 R2 Vaš preglednik podržava TLS 1.2.

Microsoft Internet Explorer Mobile

Verzija preglednika Microsoft Internet Explorer Mobile Operacijski sustav Smjernice za korisnika
v7 - Windows Phone 7
- Window Phone 7.5
- Window Phone 7.8
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v9 - Windows Phone 7
- Window Phone 7.5
- Window Phone 7.8
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v10 Windows Phone 8 Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
v11 Windows Phone 8.1 Vaš preglednik podržava TLS 1.2.

Microsoft Edge

Verzija preglednika Microsoft Edge Operacijski sustav Smjernice za korisnika
v12 Windows 10 v1507 Vaš preglednik podržava TLS 1.2.
v13 Windows 10 v1511 Vaš preglednik podržava TLS 1.2.
v14 Windows 10 v1607 Vaš preglednik podržava TLS 1.2.
v15 Windows 10 v1703 Vaš preglednik podržava TLS 1.2.
v16 Windows 10 v1709 Vaš preglednik podržava TLS 1.2.

Opera

Verzija preglednika Opera Operacijski sustavi Smjernice za korisnika
v1 do v9 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android 4.0 i noviji
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v10 do v12.17 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android 4.0 i noviji
Morate omogućiti podršku za TLS 1.2 u svom pregledniku.
v12.18 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android 4.0 i noviji
Vaš preglednik podržava TLS 1.2.
v14 do v16 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android - 4.0 i noviji
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v17 do v45 - Windows 7 i noviji
- Mac OS X 10.9 i noviji
- Linux
- Android - 4.0 i noviji
Vaš preglednik podržava TLS 1.2.

Apple Safari

Verzija preglednika Safari Operacijski sustavi Smjernice za korisnika
v1 - Mac OS X 10.2 i noviji Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v2 do v5 - Mac OS X 10.4, 10.5, 10.6, 10.7
- Windows XP
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v6 - MAC OS X 10.8 Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v7 do v10 - Mac OS X 10.9, 10.10, 10.11, 10.12, 10.13
- iOS 1.0 i noviji
Vaš preglednik podržava TLS 1.2.
v3 do v5 (iOS 3 i 4) - Mac OS X 10.2 i noviji
- iOS 1.0 i noviji
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v3 do v5 (iOS 3 i 4) - Mac OS X 10.2 i noviji
- iOS 1.0 i noviji
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.

Apple Safari Mobile

Verzija Safari Mobile Operacijski sustavi Smjernice za korisnika
v3 iOS 1
iOS 2
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v4 do v5 iOS 3
iOS 4
Vaš web-preglednik ne podržava TLS 1.2 i potrebno ga je ažurirati.
v5 do v6 iOS 5
iOS 6
Vaš preglednik podržava TLS 1.2.
v7 iOS 7 Vaš preglednik podržava TLS 1.2
v8 iOS 8 Vaš preglednik podržava TLS 1.2
v9 iOS 9 Vaš preglednik podržava TLS 1.2
v10 iOS 10 Vaš preglednik podržava TLS 1.2
v11 iOS 11 Vaš preglednik podržava TLS 1.2

III. Nadogradnja u cilju kompatibilnosti

1. Koraci za omogućivanje protokola TLSv1.2 u pregledniku

Na sljedećem se popisu nalaze koraci za rješavanje kompatibilnosti s protokolom TLSv1.2 za najčešće internetske preglednike.

Microsoft Internet Explorer:

Koraci za omogućivanje protokola TLS 1.2 u pregledniku Microsoft Internet Explorer

  1. Otvorite Internet Explorer i kliknite na Alati > Internetske mogućnosti.
  2. Potvrdite okvir uz TLS 1.1 i TLS 1.2 kako biste omogućili potporu za te protokole.
  3. Odaberite karticu Dodatno.
  4. Pomaknite dolje prema odjeljku Sigurnost na dnu popisa s postavkama.
  5. Potvrdite okvir uz TLS 1.1 i TLS 1.2 kako biste omogućili potporu za te protokole.
  6. Poništite okvir uz SSL 3.0 za onemogućavanje te postavke.
  7. Kliknite na Primijeni i U redu.
  8. Zatvorite i ponovno pokrenite preglednik Internet Explorer.

Vaš preglednik sada je spreman za podršku protokola TLS 1.2.

Mozilla Firefox:

Koraci za omogućivanje protokola TLS 1.2 u pregledniku Mozilla Firefox

  1. Otvorite Firefox
  2. U URL/adresnu traku unesite about:config i pritisnite Unesi.
  3. U polje Traži unesite tls. Pronađite unos security.tls.version.min i kliknite dva puta na njega.
  4. Postavite Vrijednost cijelog broja na 3 kako biste omogućili podršku za TLS 1.2.
  5. Kliknite na U redu
  6. Zatvorite i ponovno pokrenite preglednik Mozilla Firefox.

Vaš preglednik sada je spreman za podršku protokola TLS 1.2.

Google Chrome:

Koraci za omogućivanje protokola TLS 1.2 u pregledniku Google Chrome

  1. S preglednika kliknite na karticu Prilagodi u desnom uglu i kliknite Postavke.
  2. Pomaknite dolje do Mreža i kliknite na Promjena postavki proxyja
  3. Pod Internetska svojstva, kliknite karticu Napredno i pomaknite dolje do Sigurnost. Potvrdite okvir uz TLS 1.2.

Vaš preglednik sada je spreman za podršku protokola TLS 1.2.

Opera

  1. Otvorite preglednik Opera.
  2. Kliknite Ctrl i F12.
  3. Pomaknite dolje do odjeljka Mreža i kliknite Promjena postavki proxyja...
  4. Odaberite karticu Napredno.
  5. Pomaknite dolje do odjeljka Sigurnost i potvrdite okvire uz Koristi TLS 1.1 i Koristi TLS 1.2.
  6. Kliknite na U redu.
  7. Zatvorite i ponovno pokrenite preglednik Opera.

Vaš preglednik sada je spreman za podršku protokola TLS 1.2.

Apple Safari:

Ne postoje opcije za omogućavanje protokola SSL. Ako korisnik upotrebljava preglednik Safari verzije 7 ili novije, protokoli TLS 1.1 i TLS 1.2 automatski su omogućeni.

2. Nadogradnja verzije preglednika

Korisnik može posjetiti relevantne veze spomenute u nastavku za nadogradnju na najnoviju verziju preglednika.

Google Chrome
https://www.google.com/chrome/

Preglednik Google Android OS
https://play.google.com/store/apps/details?id=org.easyweb.browser&hl=en

Mozilla Firefox
https://www.mozilla.org/en-US/firefox/

Mozilla Firefox ESR
https://www.mozilla.org/en-US/firefox/organizations/

Microsoft Internet Explorer
https://www.microsoft.com/en-us/download/internet-explorer.aspx

Microsoft Internet Explorer Mobile
https://support.microsoft.com/en-us/help/12662/windows-phone-update-your-windows-phone

Opera
https://www.opera.com/o/ie-simple

Apple Safari
https://support.apple.com/downloads/safari

Apple Safari Mobile
https://support.apple.com/downloads/safari

3. Nadogradnja verzije operacijskog sustava

Korisnik se treba obratiti službi Servis i podrška za dodatnu pomoć.