Pravidlá TLSv1.2

  1. I. Riešenie problémov kompatibility
    1. 1. Testovací prehliadač pre TLSv1.2
    2. 2. Verzia testovacieho prehliadača
    3. 3. Verzia testovacieho operačného systému
  2. II. Pravidlá ohľadne kompatibility pre TLSv1.2
    1. 1. Kompatibilita operačného systému
    2. 2. Kompatibilita prehliadača
  3. III. Aktualizácia pre kompatibilitu
    1. 1. Kroky na aktiváciu TLSv1.2 v prehliadači
    2. 2. Aktualizácia verzie prehliadača
    3. 3. Aktualizácia verzie operačného systému

I. Riešenie problémov kompatibility

1. Testovací prehliadač pre TLSv1.2

Zákazník môže otestovať kompatibilnosť svojho prehliadača pre TLSv1.2 navštívením dole uvedenej URL:
https://quickstream.westpac.com.au/quickportal/BrowserTlsVersionView

Prehliadač je kompatibilný

Ak prehliadač podporuje TLSv1.2, zákazník uvidí nasledovné.

browser supports latest image version image needs to be placed

Prehliadač je nekompatibilný

Ak prehliadač nepodporuje TLSv1.2, zákazníkovi sa zobrazí nasledujúca stránka, ktorá má TLS 1.0 a TLS 1.1 deaktivované.

browser needs to updated image version image needs to be placed

2. Verzia testovacieho prehliadača

Zákazník môže otestovať svoju verziu prehliadača návštevou nasledujúceho URL:
https://www.whatismybrowser.com/

3. Verzia testovacieho operačného systému

Zákanzík môže otestovať svoju verziu OS návštevou nasledujúceho URL:
http://whatsmyos.com/

II. Pravidlá ohľadne kompatibility pre TLSv1.2

1. Kompatibilita operačného systému

Operačný sytém Verzia Zákaznícke pravidlá
Mac - Mac OS X 10.9 a starší Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný na Mac OS X 10.10 alebo novším.
Ak nie je aktualizácia operačného systému možná, potom treba zmeniť zariadenie.
Windows - Windows 3.1
- Windows XP
- Windows 95
- Windows NT
- Windows Vista
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný na Mac OS X 10.10 alebo novším.
Ak nie je aktualizácia operačného systému možná, potom treba zmeniť zariadenie.
iOS - starší ako iOS 7 Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
Ak nie je aktualizácia operačného systému možná, potom je treba zmeniť zariadenie.
Android - Android 4.4 a starší Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný na 5 alebo novší.
Ak nie je aktualizácia operačného systému možná, potom je treba zmeniť zariadenie.

2. Kompatibilita prehliadača

Google Chrome

Verzia Chrome Operačný sytém Zákaznícke pravidlá
v1 až 29 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android
- iOS 9 a novší
- Chrome OS
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v30 až 58 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android
- iOS 9 a novší
- Chrome OS
Váš prehliadač je podporovaný.

Prehliadač Google Android OS

Verzia Google Android OS Operačný sytém Zákaznícke pravidlá
v1 až v4.0.4 Android Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v4.1 až v4.4.4 Android Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
v5 až v8 Android Váš prehliadač podporuje TLS 1.2.

Mozilla Firefox

Verzia Mozilla Firefox Operačné systémy Zákaznícke pravidlá
v1 až v23 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android 4.0.3 a novší
- iOS 9.0 a novší
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v24 až v26 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android 4.0.3 a novší
- iOS 9.0 a novší
Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
v27 až v54 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android 4.0.3 a novší
- iOS 9.0 a novší
Váš prehliadač podporuje TLS 1.2.

Mozilla Firefox ESR

Verzia Mozilla Firefox ESR Operačné systémy Zákaznícke pravidlá
v10 až v17.0.10 - Windows XP SP2 a novší
- Mac OS X 10.9 a novší
- Linux
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v24 až v24.1.1 - Windows XP SP2 a novší
- Mac OS X 10.9 a novší
- Linux
Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
v31 až v52.1 - Windows XP SP2 a novší
- Mac OS X 10.9 a novší
- Linux
Váš prehliadač podporuje TLS 1.2.

Microsoft Internet Explorer

Verzia Internet Explorer Operačný sytém Zákaznícke pravidlá
IE 8 Windows XP Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
IE 8 Windows Server 2003 Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
IE 8 Windows Vista Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
IE 8 Windows 7 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači
IE 8 Windows Server 2008 Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
IE 8 Windows Server 2008 R2 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
IE 8 Windows Server 2008 R2 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
IE 9 Windows Vista Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
IE 9 Windows 7 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
IE 9 Windows Server 2008 Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
IE 9 Windows Server 2008 R2 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
IE 10 Windows 7 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
IE 10 Windows 8 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
IE 10 Windows Server 2008 R2 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
IE 10 Windows Server 2012 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
IE 11 Windows 7 Váš prehliadač podporuje TLS 1.2
IE 11 Windows Server 2008 R2 Váš prehliadač podporuje TLS 1.2.
IE 11 Windows 8.1 Váš prehliadač podporuje TLS 1.2.
IE 11 Windows Server 2012 R2 Váš prehliadač podporuje TLS 1.2.

Microsoft Internet Explorer Mobile

Verzia Internet Explorer Mobile Operačný sytém Zákaznícke pravidlá
v7 - Windows Phone 7
- Window Phone 7.5
- Window Phone 7.8
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v9 - Windows Phone 7
- Window Phone 7.5
- Window Phone 7.8
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v10 Windows Phone 8 Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
v11 Windows Phone 8.1 Váš prehliadač podporuje TLS 1.2.

Microsoft Edge

Verzia Microsoft Edge Operačný sytém Zákaznícke pravidlá
v12 Windows 10 v1507 Váš prehliadač podporuje TLS 1.2.
v13 Windows 10 v1511 Váš prehliadač podporuje TLS 1.2.
v14 Windows 10 v1607 Váš prehliadač podporuje TLS 1.2.
v15 Windows 10 v1703 Váš prehliadač podporuje TLS 1.2.
v16 Windows 10 v1709 Váš prehliadač podporuje TLS 1.2.

Opera

Verzia Opera Operačné systémy Zákaznícke pravidlá
v1 až v9 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android - 4.0 a novší
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v10 až v12.17 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android - 4.0 a novší
Musíte aktivovať podporu pre TLS 1.2 vo Vašom prehliadači.
v12.18 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android - 4.0 a novší
Váš prehliadač podporuje TLS 1.2.
v14 až v16 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android - 4.0 a novší
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v17 až v45 - Windows 7 a novší
- Mac OS X 10.9 a novší
- Linux
- Android - 4.0 a novší
Váš prehliadač podporuje TLS 1.2.

Apple Safari

Verzia Safari Operačné systémy Zákaznícke pravidlá
v1 - Mac OS X 10.2 a novší Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v2 až v5 - Mac OS X 10.4, 10.5, 10.6, 10.7
- Windows XP
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v6 - MAC OS X 10.8 Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v7 až v10 - Mac OS X 10.9, 10.10, 10.11, 10.12, 10.13
- iOS 1.0 a novší
Váš prehliadač podporuje TLS 1.2.
v3 až v5 (iOS 3 a 4) - Mac OS X 10.2 a novší
- iOS 1.0 a novší
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v3 až v5 (iOS 3 a 4) - Mac OS X 10.2 a novší
- iOS 1.0 a novší
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.

Apple Safari Mobile

Verzia Safari Mobile Operačné systémy Zákaznícke pravidlá
v3 iOS 1
iOS 2
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v4 až v5 iOS 3
iOS 4
Váš operačný systém nie je podporovaný TLS 1.2 a musí byť aktualizovaný.
v5 až v6 iOS 5
iOS 6
Váš prehliadač podporuje TLS 1.2.
v7 iOS 7 Váš prehliadač podporuje TLS 1.2
v8 iOS 8 Váš prehliadač podporuje TLS 1.2
v9 iOS 9 Váš prehliadač podporuje TLS 1.2
v10 iOS 10 Váš prehliadač podporuje TLS 1.2
v11 iOS 11 Váš prehliadač podporuje TLS 1.2

III. Aktualizácia pre kompatibilitu

1. Kroky na aktiváciu TLSv1.2 v prehliadači

Nasledujúce kroky vyriešia kompatibilitu TLSv1.2 pre väčšinu bežných internetových prehliadačov.

Microsoft Internet Explorer:

Kroky na aktivovanie TLS 1.2 v prehliadači Microsoft Internet Explorer

  1. Otvorte Internet Explorer a kliknite na Nástroje > Možnosti internetu.
  2. Označením políčok vedľa TLS 1.1 a TLS 1.2 aktivujete podporu pre tieto protokoly.
  3. Vyberte si záložku Pokročilé.
  4. Zrolujte dole k sekcii Bezpečnosť dole na zozname nastavení.
  5. Označením políčok vedľa TLS 1.1 a TLS 1.2 aktivujete podporu pre tieto protokoly.
  6. Zrušte výber vedľa SSL 3.0 a deaktivujte toto nastavenie.
  7. Kliknite na Použiť a OK.
  8. Zatvorením svojho prehliadača reštartujete Internet Explorer.

Váš prehliadač nie je pripravený na podporu protokolu TLS 1.2.

Mozilla Firefox:

Kroky na aktiváciu TLS 1.2 v Mozilla Firefox

  1. Otvorte Firefox
  2. Do URL/lišty adresy zadajte about:config a stlačte Enter.
  3. Do políčka Vyhľadávanie zadajte tls. Nájdite a dvakrát kliknite na zadanie pre security.tls.version.min
  4. Nastavte Integer hodnotu na 3 a aktivujte podporu pre TLS 1.2.
  5. Kliknite OK
  6. Zatvorte svoj prehliadač a reštartujte Mozillu Firefox.

Váš prehliadač nie je pripravený na podporu protokolu TLS 1.2.

Google Chrome:

Kroky na aktiváciu TLS 1.2 v Google Chrome

  1. Z prehliadača kliknite na záložku úprava v pravom hornom rohu a kliknite na nastavenia.
  2. Zrolujte dole k Sieti a kliknite na zmeniť nastavenia proxy.
  3. Vo vlastnostiach internetu kliknite na záložku pokročilé a zrolujte dole k položke Bezpečnosť. Označte políčko TLS 1.2.

Váš prehliadač nie je pripravený na podporu protokolu TLS 1.2.

Opera

  1. Otvorte Operu
  2. Kliknite na Ctrl a F12.
  3. Zrolujte dolu k sekcii Sieť a kliknite na Zmeniť nastavenia proxy...
  4. Vyberte si záložku Pokročilé.
  5. Zrolujte dole k položke Bezpečnosť a označte políčka vedľa Použiť TLS 1.1 a použiť TLS 1.2.
  6. Kliknite na Ok.
  7. Zatvorte svoj prehliadač a reštartujte Operu.

Váš prehliadač nie je pripravený na podporu protokolu TLS 1.2.

Apple Safari:

Na aktiváciu SSL protokolov neexistujú žiadne možnosti. Ak zákazník používa verziu Safari 7 alebo novšiu, TLS 1.1 a TLS 1.2 sú automaticky aktivované.

2. Aktualizácia verzie prehliadača

Zákazník môže navštíviť dole uvedené príslušné odkazy, aby si mohol zaktualizovať najnovšiu verziu prehliadača.

Google Chrome
https://www.google.com/chrome/

Google Android OS Browser
https://play.google.com/store/apps/details?id=org.easyweb.browser&hl=en

Mozilla Firefox
https://www.mozilla.org/en-US/firefox/

Mozilla Firefox ESR
https://www.mozilla.org/en-US/firefox/organizations/

Microsoft Internet Explorer
https://www.microsoft.com/en-us/download/internet-explorer.aspx

Microsoft Internet Explorer Mobile
https://support.microsoft.com/en-us/help/12662/windows-phone-update-your-windows-phone

Opera
https://www.opera.com/o/ie-simple

Apple Safari
https://support.apple.com/downloads/safari

Apple Safari Mobile
https://support.apple.com/downloads/safari

3. Aktualizácia verzie operačného systému

Zákazník musí kontaktovať zákaznícky servis pre ďalšiu pomoc.