TLSv1.2 Kılavuzu

  1. I. Uyumluluk Sorunu Giderme
    1. 1. TLSv1.2 tarayıcı uyumluluğu kontrolü
    2. 2. Tarayıcı versiyonu kontrolü
    3. 3. İşletim sistemi versiyonu kontrolü
  2. ii. TLSv1.2 Uyumluluk Kılavuzu
    1. 1. İşletim Sistemi Uyumluluğu
    2. 2. Tarayıcı Uyumluluğu
  3. iii. Uyumluluk için Yükseltme
    1. 1. Tarayıcıda TLSv1.2 etkinleştirme adımları
    2. 2. Tarayıcı Versiyonunu Yükseltme
    3. 3. İşletim Sistemi Versiyonu Yükseltme

I. Uyumluluk Sorunu Giderme

1. TLSv1.2 tarayıcı uyumluluğu kontrolü

Üyeler aşağıdaki URL üzerinden tarayıcılarının TLSv1.2 uyumunu kontrol edebilirler:
https://quickstream.westpac.com.au/quickportal/BrowserTlsVersionView

Tarayıcı uyumlu

Tarayıcının TLSv1.2'yi desteklemesi halinde üyeler aşağıdaki yazıyı görür.

Tarayıcı uyumlu değil

Tarayıcının TLSv1.2'yi desteklememesi halinde üyeler, TLS 1.0 ve TLS 1.1'nin devre dışı olduğu aşağıdaki sayfayı görürler.

2. Tarayıcı versiyonu kontrolü

Aşağıdaki URL adresine giderek tarayıcı versiyonuzu kontrol edebilirsiniz:
https://www.whatismybrowser.com/

3. İşletim sistemi versiyonu kontrolü

Aşağıdaki URL adresine giderek tarayıcı versiyonuzu kontrol edebilirsiniz:
http://whatsmyos.com/

ii. TLSv1.2 Uyumluluk Kılavuzu

1. İşletim Sistemi Uyumluluğu

İşletim Sistemi Versiyon Kullanıcı Kılavuzu
Mac - Mac OS X 10.9 ve aşağısı İşletim sisteminiz TLS 1.2'yi desteklemiyor ve Mac OS X 10.10 veya daha yeni bir sisteme yükseltilmek zorunda
İşletim sistemi yükseltmesinin gerçekleşmemesi halinde cihazın değiştirilmesi gereklidir.
Windows - Windows 3.1
- Windows XP
- Windows 95
- Windows NT
- Windows Vista
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve Windows 7 veya daha yeni bir sisteme yükseltilmek zorunda
İşletim sistemi yükseltmesinin gerçekleşmemesi halinde cihazın değiştirilmesi gereklidir.
iOS - iOS 7 altı İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmesi gerekli.
İşletim sistemi yükseltmesi mümkün değilse cihazın değiştirilmesi gereklidir.
Android - Android 4.4 ve altı İşletim sisteminiz TLS 1.2'yi desteklemiyor ve 5 veya üzeri bir sisteme yükseltilmesi gerekli.
İşletim sistemi yükseltmesi mümkün değilse cihazın değiştirilmesi gereklidir.

2. Tarayıcı Uyumluluğu

Google Chrome

Chrome Versiyonu İşletim Sistemi Kullanıcı Kılavuzu
v1 through 29 - Windows 7 ve yukarısı
- Mac OS X 10.9 and up
- Linux
- Android
- iOS 9 ve yukarısı
- Chrome OS
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v30 through 58 - Windows 7 ve yukarısı
- Mac OS X 10.9 and up
- Linux
- Android
- iOS 9 ve yukarısı
- Chrome OS
İnternet tarayıcınız destekleniyor.

Google Android OS Tarayıcıs

Google Android OS Versiyonu İşletim Sistemi Kullanıcı Kılavuzu
v4.0.4 üzerinden v1 Android İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v4.4.4 üzerinden v4.1 Android Tarayıcınızın TLS 1.2 desteğini etkinleştirmek zorundasınız.
v8 üzerinden v5 Android Tarayıcınız TLS 1.2'yi destekliyor.

Mozilla Firefox

Mozilla Firefox Versiyonu İşletim Sistemleri Kullanıcı Kılavuzu
v23 üzerinden v1 - Windows 7 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
- Android 4.0.3 ve yukarısı
- iOS 9.0 ve yukarısı
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmeek zorunda.
v26 üzerinden v24 - Windows 7 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
- Android 4.0.3 ve yukarısı
- iOS 9.0 ve yukarısı
Tarayıcınızın TLS 1.2 desteğini etkinleştirmek zorundasınız.
v54 üzerinden v27 - Windows 7 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
- Android 4.0.3 ve yukarısı
- iOS 9.0 ve yukarısı
Tarayıcınız TLS 1.2'yi destekliyor.

Mozilla Firefox ESR

Mozilla Firefox ESR Versiyonu İşletim Sistemleri Kullanıcı Kılavuzu
v17.0.10 üzerinden v10 - Windows XP SP2 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v24.1.1 üzerinden v24 - Windows XP SP2 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
Tarayıcınızın TLS 1.2 desteğini etkinleştirmek zorundasınız.
v52.1 üzerinden v31 - Windows XP SP2 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
Tarayıcınız TLS 1.2'yi destekliyor.

Microsoft Internet Explorer

Internet Explorer Mobil Versiyonu İşletim Sistemi Kullanıcı Kılavuzu
IE 8 Windows XP İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
IE 8 Windows Server 2003 İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
IE 8 Windows Vista İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
IE 8 Windows 7 Tarayıcınızda TLS 1.2 desteğini etkinleştirmek zorundasınız.
IE 8 Windows Server 2008 İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
IE 8 Windows Server 2008 R2 Tarayıcınızda TLS 1.2 desteğini etkinleştirmek zorundasınız.
IE 8 Windows Server 2008 R2 Tarayıcınızda TLS 1.2 desteğini etkinleştirmek zorundasınız.
IE 9 Windows Vista İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
IE 9 Windows 7 Tarayıcınızda TLS 1.2 desteğini etkinleştirmek zorundasınız.
IE 9 Windows Server 2008 İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
IE 9 Windows Server 2008 R2 Tarayıcınızda TLS 1.2 desteğini etkinleştirmek zorundasınız.
IE 10 Windows 7 Tarayıcınızın TLS 1.2 desteğini etkinleştirmek zorundasınız.
IE 10 Windows 8 Tarayıcınızın TLS 1.2 desteğini etkinleştirmek zorundasınız.
IE 10 Windows Server 2008 R2 Tarayıcınızın TLS 1.2 desteğini etkinleştirmek zorundasınız.
IE 10 Windows Server 2012 Tarayıcınızın TLS 1.2 desteğini etkinleştirmek zorundasınız.
IE 11 Windows 7 Tarayıcınız TLS 1.2'yi destekliyor.
IE 11 Windows Server 2008 R2 Tarayıcınız TLS 1.2'yi destekliyor.
IE 11 Windows 8.1 Tarayıcınız TLS 1.2'yi destekliyor.
IE 11 Windows Server 2012 R2 Tarayıcınız TLS 1.2'yi destekliyor.

Mobil Microsoft Internet Explorer

Internet Explorer Mobil Versiyonı İşletim Sistemi Kullanıcı Kılavuzu
v7 - Windows Phone 7
- Window Phone 7.5
- Window Phone 7.8
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v9 - Windows Phone 7
- Window Phone 7.5
- Window Phone 7.8
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v10 Windows Phone 8 Tarayıcınızın TLS 1.2 desteğini etkinleştirmek zorundasınız.
v11 Windows Phone 8.1 Tarayıcınız TLS 1.2'yi destekliyor.

Microsoft Edge

Microsoft Edge Versiyonu İşletim Sistemi Kullanıcı Kılavuzu
v12 Windows 10 v1507 Tarayıcınız TLS 1.2'yi destekliyor.
v13 Windows 10 v1511 Tarayıcınız TLS 1.2'yi destekliyor.
v14 Windows 10 v1607 Tarayıcınız TLS 1.2'yi destekliyor.
v15 Windows 10 v1703 Tarayıcınız TLS 1.2'yi destekliyor.
v16 Windows 10 v1709 Tarayıcınız TLS 1.2'yi destekliyor.

Opera

Opera Versiyonu İşletim Sistemleri Kullanıcı Kılavuzu
v9 üzerinden v1 - Windows 7 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
- Android - 4.0 ve yukarısı
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v12.17 üzerinden v10 - Windows 7 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
- Android - 4.0 ve yukarısı
Tarayıcınızın TLS 1.2 desteğini etkinleştirmek zorundasınız.
v12.18 - Windows 7 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
- Android - 4.0 ve yukarısı
Tarayıcınız TLS 1.2'yi destekliyor.
v16 üzerinden v14 - Windows 7 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
- Android - 4.0 ve yukarısı
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v45 üzerinden v17 - Windows 7 ve yukarısı
- Mac OS X 10.9 ve yukarısı
- Linux
- Android - 4.0 ve yukarısı
Tarayıcınız TLS 1.2'yi destekliyor.

Apple Safari

Safari Versiyonu İşletim Sistemleri Kullanıcı Kılavuzu
v1 - Mac OS X 10.2 ve yukarısı İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v5 üzerinden v2 - Mac OS X 10.4, 10.5, 10.6, 10.7
- Windows XP
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v6 - MAC OS X 10.8 İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v10 üzerinden v7 - Mac OS X 10.9, 10.10, 10.11, 10.12, 10.13
- iOS 1.0 ve yukarısı
Tarayıcınız TLS 1.2'yi destekliyor.
v5 üzerinden v3 (iOS 3 ve 4) - Mac OS X 10.2 ve yukarısı
- iOS 1.0 ve yukarısı
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v5 üzerinden v3 (iOS 3 ve 4) - Mac OS X 10.2 ve yukarısı
- iOS 1.0 ve yukarısı
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.

Mobil Apple Safari

Safari Mobil Versiyonu İşletim Sistemleri Kullanıcı Kılavuzu
v3 iOS 1
iOS 2
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v5 üzerinden v4 iOS 3
iOS 4
İşletim sisteminiz TLS 1.2'yi desteklemiyor ve yükseltilmek zorunda.
v6 üzerinden v5 iOS 5
iOS 6
Tarayıcınız TLS 1.2'yi destekliyor.
v7 iOS 7 Tarayıcınız TLS 1.2'yi destekliyor.
v8 iOS 8 Tarayıcınız TLS 1.2'yi destekliyor.
v9 iOS 9 Tarayıcınız TLS 1.2'yi destekliyor.
v10 iOS 10 Tarayıcınız TLS 1.2'yi destekliyor.
v11 iOS 11 Tarayıcınız TLS 1.2'yi destekliyor.

iii. Uyumluluk için Yükseltme

1. Tarayıcıda TLSv1.2 etkinleştirme adımları

Aşağıdaki liste adımlarını takip ederek en yaygın internet tarayıcılarında TLSv1.2 uyum sorununu çözebilirsiniz.

Microsoft Internet Explorer:

Microsoft Internet Explorer'da TLS 1.2'yi etkinleştirmek için takip etmeniz gereken adımlar:

  1. Internet Explorer'ı açın ve Araçlar > Internet Seçenekleri sekmesine tıklayın.
  2. TLS 1.1 ve TLS 1.2 protokollerini etkinleştirmek için, yanlarındaki kutucukları işaretleyin.
  3. Gelişmiş sekmesine tıklayın.
  4. Ayarlar listesinin sonundaki Güvenlik bölümüne gidin.
  5. TLS 1.1 ve TLS 1.2 protokollerini etkinleştirmek için, yanlarındaki kutucukları işaretleyin.
  6. Bu ayarı devre dışı bırakmak için SSL 3.0 kutucuğundaki işareti kaldırın.
  7. Uygula ve TAMAM kutucuklarını işaretleyin.
  8. Tarayıcınızı kapatın ve Internet Explorer'ı tekrar başlatın.

Tarayıcınız şu an TLS 1.2 protokolünü destekliyor.

Mozilla Firefox:

Mozilla Firefox tarayıcısında TLS 1.2'yi etkinleştirmek için takip etmeniz gereken adımlar

  1. Firefox tarayıcısını açın
  2. URL/adres çubuğuna about:config yazın ve Giriş butonuna basın.
  3. Arama bölümüne, tls yazın. Yerini bulun ve security.tls.version.min üzerine çift tıklayın.
  4. TLS 1.2.'yi etkinleştirmek için tamsayısal değeri 3 olarak belirleyin.
  5. Tamam sekmesine tıklayın.
  6. Tarayıcınızı kapatın ve Mozilla Firefox'u yeniden başlatın.

Tarayıcınız şu an TLS 1.2 protokolünü desteklemeye hazır.

Google Chrome:

Google Chrome'da TLS 1.2'yi etkinleştirmek için takip etmeniz gereken adımlar

  1. Tarayıcınızın en sağ köşesindeki Kişiselleştir sekmesine tıklayın ve Ayarlar bölümüne gidin.
  2. bölümü için aşağıya inin ve Proxy ayarlarını değiştir sekmesine tıklayın.
  3. İnternet Seçenekleri bölümünde gelişmiş sekmesine giderek Güvenlik bölümüne göz atın. TLS 1.2 kutucuğunu işaretleyin.

Tarayıcınız şu an TLS 1.2 protokolünü desteklemeye hazır.

Opera

  1. Opera'yı açın.
  2. Ctrl ve F12 tuşlarına basın.
  3. bölümü için aşağıya bakın ve Proxy ayarlarını değiştir sekmesine tıklayın...
  4. Gelişmiş sekmesine tıklayın.
  5. Güvenlik bölümüne gidin veTLS 1.1 ve TLS 1.2. kullanın kutucuklarını işaretleyin.
  6. Tamam sekmesine tıklayın.
  7. Tarayıcınızı kapatın ve Opera'yı tekrar başlatın.

Tarayıcınız şu an TLS 1.2 protokolünü desteklemeye hazır.

Apple Safari:

SSL protokollerini etkinleştirme seçeneğiniz bulunmuyor. Safari 7 veya yukarısı bir tarayıcı kullanıyorsanız TLS 1.1 ve TLS 1.2 otomatik olarak etkinleştirilmiştir.

2. Tarayıcı Versiyonunu Yükseltme

Kullanıcılar aşağıda belirtilen ilgili bağlantıları ziyaret ederek tarayıcılarının en yeni versiyonlarını yükleyebilirler.

Google Chrome
https://www.google.com/chrome/

Google Android OS Tarayıcısı
https://play.google.com/store/apps/details?id=org.easyweb.browser&hl=en

Mozilla Firefox
https://www.mozilla.org/en-US/firefox/

Mozilla Firefox ESR
https://www.mozilla.org/en-US/firefox/organizations/

Microsoft Internet Explorer
https://www.microsoft.com/en-us/download/internet-explorer.aspx

Microsoft Internet Explorer Mobile
https://support.microsoft.com/en-us/help/12662/windows-phone-update-your-windows-phone

Opera
https://www.opera.com/o/ie-simple

Apple Safari
https://support.apple.com/downloads/safari

Apple Safari Mobile
https://support.apple.com/downloads/safari

3. İşletim Sistemi Versiyonu Yükseltme

Daha fazla yardım için üyelerin Müşteri Hizmetleri ekibimizle iletişime geçmeleri gerekmektedir.